14 Dec 2014, 10:54

Download

The current stable version of REMITT is 0.5.0.

Please note that REMITT 0.5.0+ is required for FreeMED 0.9.0+, and REMITT 0.4.x is required for FreeMED 0.8.x.

Downloads for the REMITT package are available courtesy of sourceforge.net.

Downloads